PinoStudio 1

Full Version: ¿Cómo actualizar PHP en macOS Sierra?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Actualizar PHP en macOS Sierra
Existe una página web llamada php-osx.liip.ch que nos brinda un paquete que contiene PHP 7 (u otras versiones), y que podremos instalarlo desde un sólo comando en nuestra Mac (OS X / macOS 10.6 – 10.12).


Paso I.


Quote:curl -s https://php-osx.liip.ch/install.sh | bash -s 7.1

Copia el comando anterior, y pégalo en tu terminal; pero antes, ¿notas que dice 7.1? Ahi tú puedes borrar el 7.1 y ponerle una de las siguientes versiones: 7.1, 7.0, 5.6, 5.5, 5.4 ó 5.3.
Después de que hayas escogido la versión a instalar, ejecutas el comando y empezará a instalar la versión de PHP que seleccionaste, no sin antes pedirte la contraseña para continuar.

Paso II.
Una vez instalado, puedes verificar la versión instalada desde tu terminal con el siguiente comando:



Quote:php --version

Podría suceder de que tu terminal muestre que tienes la versión 5.6.30, la que viene por defecto:

1

Quote:PHP 5.6.30 (cli) (built: Feb 7 2017 16:18:37)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies



Si esto ocurre, sólo tienes que ejecutar este comando:



Quote:export PATH=/usr/local/php5/bin:$PATH


Revisa de nuevo la versión, y ahora tiene que salir correctamente:



Quote:PHP 7.1.4 (cli) (built: May 6 2017 10:02:00) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies


Resultados
Lo anterior debería funcionar, al menos funcionó para mí. La verdad es que solamente ocupo PHP desde la terminal para ejecutar scripts básicos, probar funciones, entre otros.

Referencia:
Como Actualizar PHP en MacOS Sierra